Primo accesso alla routerboard

Allora avete comprato la vostra prima routerboard MikroTik,
una di quelle low-cost da usare come access point wireless o magari
una di quelle un po’ più sofisticate, con display LCD e porta seriale.
Siete soddisfatti del vostro nuovo giocattolo, ma non sapete ancora esattamente
cosa farvene? In questo post vi descrivo cosa ho fatto io nei primi giorni
in cui mi sono cimentato con questi dispositivi a me del tutto ignoti.

Il primo dispositivo MikroTik che ho avuto modo di comprare è stato
una routerboard RB2011UiAS-RM, un router con dieci porte ethernet
(5 gigabit ethernet, 5 fast ethernet) + uno slot SFP. Ho scelto questo
modello perché era tra i più economici tra quelli da montare in rack 19”.
Tuttavia non è di questo dispositivo che voglio parlarvi in questo post.

La routerboard che prendo in esame adesso è la RB941-2nD, un router con
quattro porte fast-ethernet (100 Mbps) e una scheda wireless. E’ il tipico
router/access-point pronto all’uso che potete comprare se volete
dotare di connettività wireless la vostra rete casalinga senza spendere
molto. Su Amazon si trova a meno di 30 euro.

MikroTik hAP-lite
Router wireless low cost di MikrotTik

Appena accesa, questa routerboard ha una configurazione che prevede la
prima interfaccia ethernet (ether1) come interfaccia esterna (collegata a Internet
tipicamente tramite altro router/modem),
e le restanti interfacce ethernet (ether2, ether3 ed ether4) configurate in
bridge con la scheda wireless (wlan1) per consentire la connessione dei vostri
dispositivi wireless o con cavo.

Script che applica la configurazione di default del dispositivo

Un bridge, detto in parole semplici, è un’interfaccia logica che raggruppa
più interfacce fisiche (in questo caso ether2, ether3, ether4 e wlan1), facendole
comportare come un semplice switch layer 2. L’espressione switch layer 2,
in effetti, non è altro che il modo con cui ci si riferisce ad un bridge
nella terminologia usata da Cisco Systems.

/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=pwr-line1
add bridge=bridge comment=defconf interface=wlan1

L’interfaccia di amministrazione della routerboard è accessibile
solo attraverso il bridge, usando il tool Winbox oppure un normale browser
puntando all’indirizzo http://192.168.88.1. Il bridge prevede
infatti una configurazione di default sulla rete 192.168.88.0/24 con
un server dhcp già configurato e attivo. L’account di accesso all’interfaccia amministrativa
avviene con l’utente ‘admin’ e senza alcuna password. Sta a voi, ovviamente,
impostare quanto prima una password sicura per proteggere il vostro
dispositivo da accessi non autorizzati.

/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=192.168.88.0

/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254

/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge name=defconf
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1

L’interfaccia esterna, la eth1, non permette accesso amministrativo ed ha
funzione di nat per le connessioni in uscita provenienti dai dispositivi
connessi al bridge. E’ anche configurata per bloccare qualsiasi tentativo
di connessione dall’esterno che non sia un pacchetto di risposta ad una
sessione già attiva iniziata dall’interno. Per default,
l’interfaccia esterna è configurata come client dhcp:

/ip dhcp-client
add comment=defconf disabled=no interface=ether1

Se andate a vedere più nel dettaglio la configurazione di default, vi
accorgerete che spesso non si fa riferimento diretto alle interfacce
ether1 e bridge ma si usano le cosiddette interface list. Le interface
list predefinite sono LAN (composta dall’interfaccia bridge) e WAN
(composta dall’interfaccia ether1):

/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN

Qualora la vostra routerborad non avesse a bordo la configurazione di
default appena illustrata, ad esempio perché la avete modificata o perché
si tratta di un dispositivo usato in precedenza, potete resettarla per
ripristinare la configurazione predefinita. Se avete accesso alla command
line (ssh, telnet o console), il comando per ripristinare la configurazione
è /system reset-configuration. Se invece volete procedere da Winbox,
trovate il comando in System –> Reset Configuration:

Reset della configurazione con il tool WinBox

Concludo qui questa prima descrizione di un dispositivo MikroTik. Alcuni
dei dettagli illustrati potrebbero non essere del tutto chiari, ma li
approfondiremo nei post successivi.

Utilizzando il sito, accetti l'utilizzo dei cookie da parte nostra. maggiori informazioni

Questo sito utilizza i cookie per fornire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o cliccando su "Accetta" permetti il loro utilizzo.

Chiudi